A few issues I've run into so far



  • I just installed the game a few hours ago. Here are some issues I ran into since installing. Hope this helps.

    1. When I first loaded the game and tried to accept the terms and conditions. I couldn't click continue or cancel. I tried to change to desktop and back, but then when I clicked continue it would only take me back to the desktop. There tried to exit the game but I wasn't given an option too. I used task manager to close the game. I tried to relaunch the game but the twitch launcher still showed the game as running. So I restarted my PC.

    2. After restarting my PC I ran into another problem. When trying to launch the game. I received the error "Launch failure Your game failed to launch. If the problem persists, please contact customer support." I received the error twice. I contacted support. I did contact support but was seemingly able to fix it by restarting again.

    3. This happened while in the tutorial. I was instructed to press " 1 " and build a catapult. I pressed it numerous times with nothing appearing. I tried moving around to different areas but nothing seemed to work until I moved within range of the enemies buildable then pressed 1. After that building, the catapult seemed to work without a problem.

    I only played one match so far, but it seems quite fun.


Log in to reply
 

Looks like your connection to Breakaway was lost, please wait while we try to reconnect.